Verification is currently underway for the maintenance items.
Posted May 30, 2025 - 20:45 GMT+03:00
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 30, 2025 - 19:45 GMT+03:00
Scheduled
Deposit and withdrawal services on the Hedera (HBAR) network will be suspended on May 30th at 19:45 due to the upcoming network upgrade to ensure the integrity and security of transactions.
Our team will be closely monitoring the upgrade process, and services will be restored as soon as the network is confirmed to be stable. Further updates will be provided as necessary.
Posted May 29, 2025 - 14:44 GMT+03:00
This scheduled maintenance affected: Hedera (Crypto Deposit, Crypto Withdrawal).